{"_id":"56cdcd6249abf10b0036a2e6","__v":6,"version":{"_id":"552829408962f339009a6790","project":"552829408962f339009a678d","__v":26,"createdAt":"2015-04-10T19:49:20.516Z","releaseDate":"2015-04-10T19:49:20.516Z","categories":["552829418962f339009a6791","55284ed68962f339009a67e1","55286c73391a362500d9b3f4","552918f6b316811900149f59","5529b255d739240d00a3483e","553287590a578a0d008d4ff5","55329385e7d1fa0d003fc946","5550b55200420e0d00d1312f","55525fca953c9c0d00f507d7","559199695631432f002d358a","559d8d96980b801700d5ec7e","55c5e833cccdeb2d004e24b9","55d76504f662951900fc0e7d","55ea213cc62aa02f008229cd","56157b750f5ed00d00483dd8","561981fbac0924170069f4e8","561b8b1ea430930d0037ea67","563417428b86331700b488ca","56cd785bface161300dae0ec","56cdcc6e70db8a15006395f4","56cdf1b749abf10b0036a34a","56cedc8ce50c9c1b00830423","56e97ba8d825061900d1ac83","570d505228e6900e00477229","573614ca2ab52e1700c8e851","57d556a2496a3117004d70cf"],"is_deprecated":false,"is_hidden":false,"is_beta":false,"is_stable":true,"codename":"","version_clean":"1.0.0","version":"1.0"},"category":{"_id":"56cdcc6e70db8a15006395f4","__v":3,"pages":["56cdcd6249abf10b0036a2e6","56cdd013f6be970b00663fc0","56cdd562f099c023009791a7"],"project":"552829408962f339009a678d","version":"552829408962f339009a6790","sync":{"url":"","isSync":false},"reference":false,"createdAt":"2016-02-24T15:29:50.989Z","from_sync":false,"order":4,"slug":"web-sdk","title":"Web SDK"},"parentDoc":null,"project":"552829408962f339009a678d","user":"55282916d9e1db2d00cd923c","updates":[],"next":{"pages":[],"description":""},"createdAt":"2016-02-24T15:33:54.924Z","link_external":false,"link_url":"","githubsync":"","sync_unique":"","hidden":false,"api":{"results":{"codes":[]},"settings":"","auth":"required","params":[],"url":""},"isReference":false,"order":0,"body":"Web SDK Requirements:\n* Node.js 4.2.2+ LTS\n* Gulp 3.9.0+\n[block:api-header]\n{\n  \"type\": \"basic\",\n  \"title\": \"NodeJS Installation\"\n}\n[/block]\nWrong installation of node.js is common case for most build errors. We **strongly recommend to use 4.2.2+ LTS version**.\n\n## Step 1: Checking Node.JS verision if installed\n\nExecute\n```bash\nnode --version\n```\nVersion should be ```v4.x.x```. We don't support **NodeJS 5.x**.\n\n## Step 2: Installing fresh Node.JS\nIf you have problems, we recommend to remove node from your system and install manually.\n\nRecommended installation instructions\n* Linux: [NodeSource binary distributions](https://github.com/nodesource/distributions)\n* Windows: [Node.JS official site](https://nodejs.org/)\n* Mac OS X: With [homebrew](http://brew.sh/) execute ```brew install homebrew/versions/node4-lts```\n\n## Step 3: Checking NPM version\nExecute\n```bash\nnpm --version\n```\nVersion should be ```3.3.9``` or newer.\n\n## Step 4: Updating NPM\n\nAfter installation of Node.JS execute to get latest version\n```bash\nnpm update -g npm\n```\n[block:api-header]\n{\n  \"type\": \"basic\",\n  \"title\": \"Gulp Installation\"\n}\n[/block]\nGulp is a default build system for Actor Web Application.\n\n## Step 1: Check Gulp version\n\nExecute command:\n```bash\ngulp --version\n```\nVersion shoud be 3.9.0+\n\n## Step 2: Install Gulp with NPM\n\n```bash\nnpm install gulp -g\n```","excerpt":"Web SDK prerequisites","slug":"web-sdk-prerequisites","type":"basic","title":"Prerequisites"}

Prerequisites

Web SDK prerequisites

Web SDK Requirements: * Node.js 4.2.2+ LTS * Gulp 3.9.0+ [block:api-header] { "type": "basic", "title": "NodeJS Installation" } [/block] Wrong installation of node.js is common case for most build errors. We **strongly recommend to use 4.2.2+ LTS version**. ## Step 1: Checking Node.JS verision if installed Execute ```bash node --version ``` Version should be ```v4.x.x```. We don't support **NodeJS 5.x**. ## Step 2: Installing fresh Node.JS If you have problems, we recommend to remove node from your system and install manually. Recommended installation instructions * Linux: [NodeSource binary distributions](https://github.com/nodesource/distributions) * Windows: [Node.JS official site](https://nodejs.org/) * Mac OS X: With [homebrew](http://brew.sh/) execute ```brew install homebrew/versions/node4-lts``` ## Step 3: Checking NPM version Execute ```bash npm --version ``` Version should be ```3.3.9``` or newer. ## Step 4: Updating NPM After installation of Node.JS execute to get latest version ```bash npm update -g npm ``` [block:api-header] { "type": "basic", "title": "Gulp Installation" } [/block] Gulp is a default build system for Actor Web Application. ## Step 1: Check Gulp version Execute command: ```bash gulp --version ``` Version shoud be 3.9.0+ ## Step 2: Install Gulp with NPM ```bash npm install gulp -g ```